平台需求

平台支持

请参考 EasyAR Sense 平台要求 以及 Unity System requirements

关于 Android arm64-v8a

  • Unity使用的mono脚本后台不支持Android arm64-v8a。如果需要使用应开启IL2CPP。

关于 iOS armv7

  • EasyAR Sense 从3.0版本开始终止了对iOS armv7的支持。在库文件中存在空的代码层以确保 XCode 工程始终可以构建,但如果编译时只选择了armv7运行后功能将无法使用。

Unity兼容性

EasyAR Sense Unity Plugin需要使用 Unity 2019.4 或更高版本。

  • 通常来说, EasyAR Sense不依赖很多变化的Unity API,所以如果Unity发布了新版本,EasyAR Sense Unity Plugin一般都可以正常使用。

  • Unity 2020.2 或更高版本 删除了iOS设备的OpenGLES支持,在这些版本中,视频录制功能将无法在iOS设备上使用。

.NET API 兼容性

EasyAR Sense Unity Plugin兼容 .NET Standard 2.0 API

Graphics API

EasyAR Sense Unity Plugin 直接使用Unity的渲染管线,所有Unity中可以使用的图形API都可以天然被支持。

特例:由于EasyAR Sense的内部实现,录屏功能将只能在某些特定条件下工作,即在Android上Graphics API是OpenGLES2或OpenGLES3的情况以及在iOS上Graphics API是OpenGLES3的情况。

Scriptable Render Pipeline

EasyAR Sense Unity Plugin 支持 Universal Render Pipeline (URP) 7.0.0 或更新版本。

EasyAR Sense Unity Plugin 不支持 High Definition Render Pipeline (HDRP)。

WebGL

EasyAR Sense Unity Plugin 不支持 Unity的WebGL。

EasyAR Sense的功能和接口不支持在Unity WebGL上使用,但你仍然可以通过直接调用EasyAR CRS或其它服务接口的方式使用EasyAR的云服务。这种情况你不再需要EasyAR Sense Unity Plugin,而是通过Unity的网络API直接调用EasyAR的相关云服务接口。

Unity AR Foundation 兼容性

EasyAR Sense Unity Plugin 支持 AR Foundation 4.0.8 或更新版本。

ARCore 兼容性

EasyAR Sense Unity Plugin 内部包含了ARCore SDK 1.23.0,因此可以支持 ARCore (Google Play Services for AR) 1.23.0及以上版本。从我们观察来看,1.19.0 - 1.23.0应该也是支持的,但1.19.0以下是不支持的。如果使用AR Foundation或其它ARCore SDK的发布,ARCore 兼容性将由这些框架决定。

如果有使用到 ARCore,需要在Unity中做如下两个设置

  • 使用 Gradle >= 5.6.4(默认情况下,Unity 2020及更新版本是满足条件的,因此主要在使用Unity 2019.4的时候需要注意)。详情可参考 Google的说明

  • 使用 IL2CPP 并在构建中包含 arm64-v8a 。在arm64的设备上运行仅有armv7的程序,ARCore不会正常工作。这个在打包时是非强制的,但如果不满足条件会弹出警告。

华为 AR Engine 兼容性

EasyAR Sense Unity Plugin 支持官方的 Huawei AR Engine Unity SDK 2.11.0,其发布文件是 arenginesdk-tool-2.11.0.2.zip

华为目前不再维护 AR Engine 的 Unity SDK,因此我们并不确定是否更新版本的 AR Engine 可以使用。同时,由于 Huawei AR Engine Unity SDK 使用了一些废弃的 Unity API,它不能在 Unity 2020.1 或更新版本上使用。

EasyAR Sense Unity Plugin 目前还不支持没有官方Unity SDK的华为 AR Engine。

Nreal 眼镜兼容性

以下 Nreal SDK 版本在当前EasyAR发布时已经支持:1.5.7 - 1.8.0,如果EasyAR使用到的Nreal接口在Nreal新版本中没有变化,可能也是可以直接支持的;如果这些接口存在少量变化,在EasyAR更新前也可以自行修改NrealFrameSource脚本。